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01 • Table Maker

About
This document provides an overview of available  
settings for the Divi-Modules – Table Maker module.

It discusses only those settings which are unique to  
this module and does not provide any information  
on settings which are common to most Divi modules.

For more information on common Divi module settings,  
please consult Elegant Themes online documentation.

Further more, this document provides only limited 
information on installing and activating the module.  
It assumes the reader is already familiar with these  
concepts and has some prior experience with both 
WordPress and the Divi Builder.

https://www.elegantthemes.com/documentation/divi/
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Requirements
WordPress: Version 5.0 (or higher)
PHP: Version 7.0 (or higher)
MySQL: Version 5.0 (or higher)
dom: Enabled
libxml: Enabled
mbstring: Enabled
CSS Grid: Enabled

Important: Requires the Divi Theme, Extra Theme,  
or Divi Builder Plugin to be installed and activated.

Divi-Modules plugins are created and tested using the  
latest Divi Theme and Builder versions. Backwards 
compatibility is not guaranteed, however, plugins should 
function normally with at least the following versions:

Divi Theme: Version 4.10 (or higher)
Extra Theme: Version 4.10 (or higher)
Divi Builder: Version 4.10 (or higher)

Important: This module may not function correctly  
under Divi’s Classic Editor. It ’s highly recommended that  
you choose Switch To The New Divi Builder.
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Installation
After completing your Divi-Modules purchase, you will receive a 
confirmation email providing you with your Download Link and 
Software License Key. This information can also be found in your 
Divi-Modules Account Purchases and Downloads pages.

After downloading your Divi-Modules purchase, upload it to your 
website’s WordPress Dashboard and click Activate. More detailed 
instructions on Installing WordPress Plugins can be found online.

Important!
The information on this page is for Divi-Modules website 
customers only. If you purchased your copy of this product 
from the Elegant Themes Divi Marketplace, please see page 5.

https://divi-modules.com/account/purchases/
https://divi-modules.com/account/downloads/
https://www.wpbeginner.com/beginners-guide/step-by-step-guide-to-install-a-wordpress-plugin-for-beginners/
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Software License
In order to receive periodic updates, you will need to activate  
your Software License. To do this, navigate to the Divi-Modules  
menu item in your WordPress Dashboard. Go to the My Modules 
submenu, enter your Software License Key, and click Activate.

To manage your Software License, please login to your  
Divi-Modules Account Purchases page.

Important!
The information on this page is for Divi-Modules website 
customers only. If you purchased your copy of this product 
from the Elegant Themes Divi Marketplace, please see page 5.

https://divi-modules.com/account/purchases/
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Divi Marketplace
If your copy of this product was purchased from the Elegant  
Themes Divi Marketplace your account and product license is  
with Elegant Themes, not Divi-Modules.

You will not receive a Divi-Modules Account or a Software License  
Key from Divi-Modules. Your product will also not include the  
Divi-Modules menu as described on the previous pages.

Instead, in order to receive periodic updates you will need to  
ensure that you have an active product subscription through the 
Divi Marketplace and that your Divi API Key is correctly entered  
into the Divi Theme Options of your website.

For all product licensing enquiries see your Divi Marketplace 
Customer Dashboard or contact Elegant Themes Support.

Important!
The information on this page is for Elegant Themes Divi 
Marketplace customers only. If you purchased your copy of this 
product from the Divi–Modules website, please see page 4.

https://www.elegantthemes.com/marketplace/customer-dashboard/
https://www.elegantthemes.com/marketplace/customer-dashboard/
https://www.elegantthemes.com
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Table Maker
Divi-Modules – Table Maker brings beautiful responsive 
tables to the Divi Builder. With features including…

•  Multiple headers and footers
•  Column and row spanning
•  Icon, button and image cells
•  Accordion view for mobile
•  Scrolling with sticky headers
•  and much more…

Style every part of the table from content  
to columns, headers to footers, right down to 
individual cells without the need for third-party 
plugins and shortcodes.
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Module Features
In this section of the documentation we’ll highlight the 
main features of the Table Maker module. For each 
feature you will find page references to more detailed 
information for configuring and styling the table.
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Module Parts
A Table Maker module consists of a table  
and optional table title and description.

A) Table Title
>  See here for more information.

B) Table Content
>  See here for more information.

C) Table Description
>  See here for more information.
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Table Parts
A Table Maker table consists of columns,  
rows and individual table cells.

A) Table Column
>  See here for more information.

B) Table Row
>  See here for more information.

C) Table Cell
>  See here for more information.
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Headers & Footers
A Table Maker table can include multiple 
column headers, column footers, row headers 
and row footers.

A) Column Header
>  See here for more information.

B) Column Footer
>  See here for more information.

C) Row Header
>  See here for more information.

D) Row Footer
>  See here for more information.

A
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Corner Cells
The overlapping corner cells of a Table Maker 
table can be individually styled and the top-left 
corner cells can be set to be visible or hidden.

A) Top-Left Corner
>  See here for more information.

B) Top-Right Corner
>  See here for more information.

C) Bottom-Left Corner
>  See here for more information.

D) Bottom-Right Corner
>  See here for more information.

C

BA

D



Mike

Column 2–4

Alpha

Bravo

Charlie

Delta

Echo

Foxtrot

Golf

Hotel

India

Juliett

Kilo

Lima

Zulu

November

Oscar

Column 5–7

Papa

Quebec

Romeo

Sierra

Tango

Uniform

Victor

Whiskey

X-ray

Yankee

Row 2

Row 3

Row 4

Row 5

Row 6

Row 7

12 • Table Maker

Colspan & Rowspan
Table Maker table cells can span  
across multiple columns and rows.

A) Column Span
>  See here for more information.

B) Row Span
>  See here for more information.
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Lines & Gaps
Table Maker table cells can be  
separated by lines or gaps.

A) Lines
>  See here for more information.

B) Gaps
>  See here for more information.
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Stripes & Hover
A Table Maker table can include  
alternating stripes and hover effect.

A) Stripes
>  See here for more information.

B) Hover
>  See here for more information.
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Scrolling & Sticky Headers
A Table Maker table can be set to  
scroll horizontally and vertically with  
or without sticky headers.

A) Vertical Scrolling
>  See here for more information.

B) Horizontal Scrolling
>  See here for more information.

A

B



Row 1

Row 1

Row 1

Row 1

Row 1

Row 2

Row 2

Row 2

Row 2

Row 2

Row 3

Row 3

Row 3

Row 3

Row 3

Column 1 Column 1

Column 2

Column 2

Column 3

Column 3

Column 4

Column 4

Alpha

Delta

Delta

Golf

Juliett

Bravo

Echo

Echo

Hotel

Kilo

Charlie

Foxtrot

Foxtrot

India

Lima

16 • Table Maker

Blocks & Accordion
Table Maker table columns and rows  
can also be displayed as individual blocks  
or as an interactive accordion.

A) Blocks
>  See here for more information.

B) Accordion
>  See here for more information.
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Content Types
Table Maker table content can include  
text, images, icons and buttons.

A) Text
>  See here for more information.

B) Images
>  See here for more information.

C) Icons
>  See here for more information.

D) Buttons
>  See here for more information.
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Text Styling
Table Maker table text styling options include 
text-wrap, font, font-weight, font-style, text-
color, text-size, letter-spacing, line-height, and 
text-shadow. Styles can be set for the whole 
table and per individual column.

A) Table Text
>  See here for more information.

B) Column Text
>  See here for more information.

A B
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Cell Styling
Table Maker table cell styling options include 
background-color, horizontal-alignment, vertical-
alignment, padding, rounded-corners, border-
styles, and box-shadow. Styles can be set for the 
whole table and per individual column.

A) Table Cells
>  See here for more information.

B) Column Cells
>  See here for more information.

A B
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Getting Started
In this section of the documentation we’ll show 
some of the most common steps for creating  
Table Maker tables. For each step you will find  
page references to more detailed information  
for configuring and styling the table.
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Step 1
Install and activate your copy of Table Maker  
in the Wordpress > Admin > Plugins area.

>  See here for more information.

Step 2
Open a page or post in the Divi Builder and add a Section, Row  
and Columns. Table Maker should then appear as one of the available 
modules in the Insert Module window.

1

2
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Step 3
Click on the Table Maker Settings > Add New Column button to begin  
making the table. Continue clicking the Add New Column button to  
add as many columns as the table needs.

>  See here for more information.

Step 4
Enter content for each row of the column in the Column Settings > Content 
> Column Content > Col: Rows field – one row in the editor equals one row 
in the table. Repeat Step 3 and 4 to add more columns to the table.

>  See here for more information.

3

4
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Step 5
Add an optional title and description to the table using the Table Maker 
Settings > Content > Table Title and Table Description settings.

>  See here for more information.

Step 6
Use the Table Maker Settings > Content > Table Columns and Table Rows 
settings to configure the table’s headers and footers and set the 
minimum and maximum sizes for the table’s columns and rows.

>  See here for more information.

5

6
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Step 7
Use the Table Maker Settings > Content > Table Responsive and Table 
Scrolling settings to set how the table looks when space is limited.

>  See here for more information.

Step 8
Use the Table Maker Settings > Design > Table Frame settings to set the  
gap between tables cells or to separate cells with a custom line style.

>  See here for more information.

7

8
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Step 9
Use the Table Maker Settings > Design > Table Stripes and Table Hover 
settings to add horizontal or vertical stripes and hover effects.

>  See here for more information.

Step 10
Use the Table Maker Settings > Design > Table Cells, Column Header Cells, 
Column Footer Cells, Row Header Cells and Row Footer Cells settings to style 
the appearance of the table cells.

>  See here for more information.

9

10
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Step 11
Use the Table Maker Settings > Design > Table Text, Column Header Text, 
Column Footer Text, Row Header Text and Row Footer Text settings to style 
the appearance of the table text.

>  See here for more information.

Step 12
Use Column Settings settings to override the Table Maker Settings  
and style the appearance of individual columns within the table.

>  See here for more information.

11 12
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Step 13
Add images, icons and buttons to the table content and style them  
with the Table Maker Settings > Content > Table Images, Table Icons and 
Table Buttons settings.

>  See here for more information.

Step 14
Use advanced cell styling options like column span  
and row span to further configure the table.

>  See here for more information.

13

14
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Content Tab
In this section of the documentation we’ll go through the 
available settings in the Content Tab. Many of the settings  
in the Content Tab are available in both Table Maker Settings 
and the individual Column Settings.

When building the table you should use the Table Maker 
Settings first to configure and style your whole table.  
Then use the Column Settings to style individual columns 
only as necessary.

A) Table Maker Settings
Settings in the Table Maker Settings effect the whole table.

B) Column Settings
Settings in the Column Settings effect only a single column.

Note: We will not discuss the Link, Background, or Admin 
Label settings as they are common to most Divi modules.

A B
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Add New Column
Table Maker tables are made of columns. You can add as 
many columns as you need, and open, duplicate and delete 
them using the column icons provided. Columns can be 
reordered by clicking and dragging them in the builder.

A) Add New Column
Adding a new column opens the Column Settings.  
There you can begin adding content for the column’s rows 
in the Column Content > Col: Rows field.

B) Col: Label
Here you can set a label for the column in the builder.  
The label will not be shown on the front end.

C) Col: Rows
Here you can enter content for the column’s rows.  
Rows are numbered so that one row in the editor equals 
one row in the table.

>  See here for more information.

A
B

C
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Table Title
Title: Mode
Here you can enable a table title. Providing a title for 
the table can help people using screen readers better 
understand the table content.

Title: Text
Here you can enter a table title.

Title: Position
Here you can position the table title above or below 
the table. When set to Hidden, the title will be visible 
to screen readers only.

>  The table title can be styled under  
the Design > Table Title toggle.
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Table Description
Description: Mode
Here you can enable a table description. Providing a 
description for the table can help people using screen 
readers better understand the table content.

Description: Text
Here you can enter a table description.

Description: Position
Here you can position the table description above or 
below the table. When set to Hidden, the description 
will be visible to screen readers only.

>  The table description can be styled under  
the Design > Table Description toggle.
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Table Columns
Col: Header Count
Here you can set the number of column headers 
the table will have.

>  Column headers can be styled under the  
Design > Column Header Cells and Text toggles.

Col: Footer Count
Here you can set the number of column footers 
the table will have.

>  Column footers can be styled under the  
Design > Column Footer Cells and Text toggles.

Col: Max Width
>  See next page for more information.

Col: Min Width
>  See next page for more information.
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Table Columns (Continued)
Col: Max Width
Here you can set a maximum width for the table columns. 
For flexible-width columns, it’s recommended to use  
fraction (fr) units. This can also be set to auto. For fixed-width 
columns, it’s recommended to use pixel (px) units.

Col: Min Width
Here you can set a minimum width for the table columns.  
It’s recommended to use pixel (px) units.

A) Table Maker Settings effect the whole table.
B) Column Settings effect only a single column.

A B
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Table Rows
Row: Header Count
Here you can set the number of row headers the  
table will have.

>  Row headers can be styled under the  
Design > Row Header Cells and Text toggles.

Row: Footer Count
Here you can set the number of row footers the  
table will have.

>  Row footers can be styled under the  
Design > Row Footer Cells and Text toggles.

Row: Max Height
Here you can set a maximum height for all table rows. 
For flexible-height rows, it’s recommended to set this  
to auto. For fixed-height rows, it’s recommended to use 
pixel (px) units.

Row: Min Height
Here you can set a minimum height for all table rows.  
It’s recommended to use pixel (px) units.
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Table Corners
Top-Left: Mode
Here you can choose to hide or show the top-left  
corner table cells.

Top-Left: Style
Here you can choose whether the top-left corner  
table cells will be styled as column or row headers.

Top-Right: Style
Here you can choose whether the top-right corner  
table cells will styled as column headers or row footers.

Bottom-Left: Style
Here you can choose whether the bottom-left  
corner table cells will be styled as column footers  
or row headers.

Bottom-Right: Style
Here you can choose whether the bottom-right corner 
table cells will be styled as column or row footers.

>  See here for more information.
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Table Responsive
Tables are great but don’t always work well on small screens. Responsive 
options allow you to set a breakpoint at which the table will break into 
separate columns or rows and display as either blocks or accordion.

Responsive: Mode
Here you can choose to enable table responsiveness. When enabled, the 
table will display as blocks or accordion at desktop, tablet or phone size.

Responsive: Breakpoint
Here you can set the table breakpoint. The breakpoint is the point at 
which the table will display as blocks or accordion.

Responsive: Break By
Here you can set whether the table will break by columns or rows. If set to 
Columns, each column will become a separate block or accordion section. 
If set to Rows, each row will become a separate block or accordion section.

Responsive: Display As
Here you can choose whether the table will display as blocks or accordion.

>  When Accordion is selected, the accordion can be configured  
and styled under the Design > Table Accordion toggle.

Responsive: Spacing
Here you can set the space between each block or accordion section.
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Table Scrolling
Table scrolling allows tables to be read at smaller screen sizes. 
Activate sticky headers to keep table headers pinned to the table 
edge and visible at all times.

Scrolling: Mode
Here you can choose to enable table scrolling. If set to Off, the 
table may overflow its containing element. If set to On, any 
overflow will be hidden and scrollbars will appear.

Sticky: Column Headers
Here you can choose to make column headers sticky. If set to  
Off, column headers will scroll along with table contents. If set  
to On, column headers will stick to the top edge of the table, 
remaining visible.

Sticky: Row Headers
Here you can choose to make row headers sticky. If set to Off,  
row headers will scroll along with table contents. If set to On, row 
headers will stick to the left edge of the table, remaining visible.

Important: Table scrolling is only visible when needed. Horizontal 
scrolling will be visible when the table is wider than the available 
space. Vertical scrolling will be visible only if the table is given a 
Height or Max-Height that is less that the height of the table.

>  See here for more information.
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Table / Column Icons
Icons can be added to the table using the <icon> tag.  
Default icon appearance is set using the options below.

Icon: Default
Here you can select the default icon.

Icon: Size
Here you can set the default icon size.

Icon: Color
Here you can set the default icon color.

A) Table Maker Settings effect the whole table.
B) Column Settings effect only a single column.

>  See here for more information.

A B
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Table / Column Buttons
Buttons can be added to the table using the <button> tag.  
Default button appearance is set using the options below.

Button: Text
Here you can set the default button text.

Button: URL
Here you can set the default button url.

Button: Target
Here you can set the default button target.

Button: Width
Here you can set the default button width. If set to Text 
Width, buttons will be as wide as their text. If set to Cell 
Width, buttons will stretch to fill their containing cell.

Use Custom Styles For Buttons
Here you can customise the appearance of the button. 
These settings are common to most Divi modules and  
are not discussed further here.

A) Table Maker Settings effect the whole table.
B) Column Settings effect only a single column.

>  See here for more information.

A B
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Table / Column Images
Images can be added to the table using the <image> tag.  
Default image appearance is set using the options below.

Image: Selection
Here you can select images to use within table cells.

Image: Quality
Here you can set the table’s default image quality or resolution.

Image: Proportion
Here you can set the default image proportion.

Image: Scale
Here you can choose how the images are scaled. 
If set to Size, you can enter a custom size for the table images.

Image: Size
Here you can set a custom size for the images.

Image: Position X & Y
Here you can set the default horizontal and vertical  
image alignment.

A) Table Maker Settings effect the whole table.
B) Column Settings effect only a single column.

>  See here for more information.

A B
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Design Tab
In this section of the documentation we’ll go through the 
available settings in the Design Tab. Many of the settings  
in the Design Tab are available in both Table Maker Settings 
and the individual Column Settings.

When building the table you should use the Table Maker 
Settings first to configure and style your whole table.  
Then use the Column Settings to style individual columns 
only as necessary.

A) Table Maker Settings
Settings in the Table Maker Settings effect the whole table.

B) Column Settings
Settings in the Column Settings effect only a single column.

Note: We will not discuss the Sizing, Spacing, Border,  
Box Shadow, Filters, Transform, or Animation settings as  
they are common to most Divi modules.

A B



42 • Table Maker

Table Title
Title: Spacing
Here you can set the space between  
the table title and the table.

Title: Heading Level
Title: Font
Title: Font Weight
Title: Font Style
Title: Text Alignment
Title: Text Color
Title: Text Size
Title: Letter Spacing
Title: Line Height
These settings are common to most Divi  
modules and are not discussed further here.

>  The table title can be enabled under the  
Table Maker Setting > Content > Table Title toggle.
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Table Description
Description: Spacing
Here you can set the space between  
the table description and the table.

Description: Font
Description: Font Weight
Description: Font Style
Description: Text Alignment
Description: Text Color
Description: Text Size
Description: Letter Spacing
Description: Line Height
These settings are common to most Divi  
modules and are not discussed further here.

>  The table description can be enabled under the  
Table Maker Settings > Content > Table Description toggle.
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Table Accordion
Accordion: Toggle State
Here you can set whether the initial state of the accordion  
toggles should be opened or closed.

Accordion: Toggle Opened
Here you can set which of the accordion toggles should be 
opened. Toggles are numbered, starting with number one.

Accordion: Icon Alignment
Here you can set the accordion toggle icon alignment.

Accordion: Icon Size
Here you can set the accordion toggle icon size.

Accordion: Icon Color
Here you can set the accordion toggle icon color.

Accordion: Icon (Closed & Opened)
Here you can set the icon for when an accordion toggle  
is closed and opened.

>  The table accordion can be enabled under the Table  
Maker Settings > Content > Table Responsive toggle.
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Table Frame
Frame: Type
Here you can set how the table frame or grid will 
display. If set to Gaps, table cells will be separated by 
a gap of your choice, allowing background colors and 
images to show through. If set to Lines, table cells will 
be separated by a line of your choice.

A) Gap: Column
Here you can set the column gap.

A) Gap: Row
Here you can set the row gap.

B) Line: Style
Here you can set the line style.

B) Line: Color
Here you can set the line color.

B) Line: width
Here you can set the line width.

A B
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Table Stripes
Stripes: Mode
Here you can choose to apply a horizontal  
or vertical stripes effect to the table.

Stripes: Responsive Mode
Here you can choose the direction of the 
stripes effect at responsive sizes.

Stripes: Order
Here you can choose whether the stripes 
effect is applied to odd or even rows and 
columns.

Stripes: Effect
Here you can choose the type of stripes effect 
to apply. When Tint is selected the stripes 
effect will be a darker or lighter version of the 
existing table colors. When Color is selected 
you can choose a custom color for the stripes 
effect. When Blend is selected, the color you 
choose for the stripes effect will be blended 
with the existing table colors.

 
Stripes: Tint
Here you can set the stripes color as a tint of 
the existing table colors. Negative values will 
darken the existing colors. Positive values will 
lighten the existing colors.

Stripes: Color (Not shown)
Here you can set a custom color for the  
stripes effect. You can use the color selector’s 
transparency slider to create subtle color 
effects. The setting is visible only when Color  
is selected as the Stripes: Effect.

Stripes: Apply To
Here you can choose which parts of the table 
the stripes effect will be applied to.
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Table Hover
Hover: Mode
Here you can choose to apply a horizontal  
or vertical hover effect to the table.

Hover: Responsive Mode
Here you can choose the direction of the  
hover effect at responsive sizes.

Hover: Effect
Here you can choose the type of hover effect 
to apply. When Tint is selected the hover effect 
will be a darker or lighter version of the 
existing table colors. When Color is selected 
you can choose a custom color for the hover 
effect. When Blend is selected, the color you 
choose for the hover effect will be blended 
with the existing table colors.

 
Hover: Tint
Here you can set the hover color as a tint of 
the existing table colors. Negative values will 
darken the existing colors. Positive values will 
lighten the existing colors.

Hover: Color (Not shown)
Here you can set a custom color for the  
hover effect. You can use the color selector’s 
transparency slider to create subtle color 
effects. The setting is visible only when Color  
is selected as the Hover: Effect.

Hover: Apply To
Here you can choose which parts of the table 
the hover effect will be applied to.
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Table / Column Text & Cells
Table Maker tables have a full suite of text and cell styling 
settings which are grouped under the following toggles:

Table Text / Column Text
Table Cells / Column Cells

Column Header Text
Column Header Cells

Column Footer Text
Column Footer Cells

Row Header Text
Row Header Cells

Row Footer Text
Row Footer Cells

All settings found in these toggles are largely the same  
as each other. To avoid repetition in the following pages  
we show only the settings for Table Text and Table Cells.

A) Table Maker Settings effect the whole table.
B) Column Settings effect only a single column.

A B
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Table / Column Text
Here you control the appearance of table/column text.

Tbl/Col: Text Wrap
Here you can choose whether to allow table/column  
text to wrap to multiple lines.

Tbl/Col: Font
Tbl/Col: Font Weight
Tbl/Col: Font Style
Tbl/Col: Text Color
Tbl/Col: Text Size
Tbl/Col: Letter Spacing
Tbl/Col: Line Height
These settings are common to most Divi  
modules and are not discussed further here.

A) Table Maker Settings effect the whole table.
B) Column Settings effect only a single column.

A B
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Table / Column Cells
Here you control the appearance of table/column cells.

Tbl/Col: Background Color
Here you can set the table/column cell background color.

Tbl/Col: Horizontal Alignment
Here you can set the horizontal alignment of  
table/column cell content.

Tbl/Col: Vertical Alignment
Here you can set the vertical alignment of  
table/column cell content.

Tbl/Col: Padding
Here you can set the table/column cell padding.

Tbl/Col: Rounded Corners
Tbl/Col: Border Styles
Tbl/Col: Box Shadow
These settings are common to most Divi  
modules and are not discussed further here.

A) Table Maker Settings effect the whole table.
B) Column Settings effect only a single column.

A B
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Advanced Tab
In this section of the documentation we’ll go through the 
available settings in the Advanced Tab. Some of the settings  
in the Advanced Tab are available in both Table Maker 
Settings and the individual Column Settings.

When building the table you should use the Table Maker 
Settings first to configure and style your whole table.  
Then use the Column Settings to style individual columns 
only as necessary.

A) Table Maker Settings
Settings in the Table Maker Settings effect the whole table.

B) Column Settings
Settings in the Column Settings effect only a single column.

Note: We will not discuss the CSS ID & Classes, Attributes, 
Conditions, Visibility, Transitions, Position, or Scroll Effects 
settings as they are common to most Divi modules.

A B
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Custom CSS
Here you can add custom CSS to customize  
the following table parts.

Before
Main Element
After
Title
Description
Table
Table Blocks
Table Cells / Column Cells
Table Content / Column Content
Column Header Cells
Column Header Content
Column Footer Cells
Column Footer Content
Row Header Cells
Row Header Content
Row Footer Cells
Row Footer Content
Table Icons / Column Icons
Table Buttons / Column Buttons
Table Images / Column Images

A) Table Maker Settings effect the whole table.
B) Column Settings effect only a single column.

A B
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Table Content
In this section of the documentation we’ll explain  
how to add text, html, links, shortcodes, icons,  
buttons, and images to Table Maker tables.
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Adding Text
A) Adding Text
Table Maker tables are made of columns. To add text 
content to a column, simply enter the text into the Column 
Settings > Content > Column Content > Col: Rows field. Rows 
are numbered so that one row in the editor equals one  
row in the table.

B) Adding Multiple Lines Of Text
To add multiple lines of text to a single cell you can use  
the HTML <br> tag, which can also be written as <br />.

>  See next page for more information.

A

B
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Adding HTML
The Column Settings > Content > Column Content > Col: Rows 
field is an HTML editor, so as well as entering plain text you 
can also use HTML to markup and style the table content.

Using HTML in the table content can greatly expand Table 
Maker’s creative possibilities. The examples shown on this 
page are not meant to be a tutorial but simply meant to give 
you a quick idea of what might be possible.

1) Header Text
2) Bold Text
3) Italic Text
4) Text Color
5) Font Weight
6) Line Break
7) Hyperlink
8) Unordered List

>  If you are unfamiliar with HTML there  
are many tutorials available online.

>  See next page for more information.

1 <h3>This is a header</h3>
2 This is <strong>bold</strong>.
3 This is <em>italic</em>.
4 This is <span style="color:#ff0000;">red</span>.
5 This is <span style="font-weight:800;">heavy</span>.
6 This is<br>three lines of text<br>in a single cell.
7 <a href="https://divi-modules.com">This is a link</a>
8 <ul><li>Item 1</li><li>Item 2</li><li>Item 3</li><ul>

https://www.w3schools.com/html/
https://www.w3schools.com/html/
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Adding Links
There a five ways to add links to table content.

1) Hyperlinks
Any content can be made into a link with  
standard HTML hyperlink notation.
>  See more about hyperlinks here.

2) Cells
A single table cell can be made into a link  
with Table Maker’s <cell> tag.
>  See here for more information.

3) Icon
Icon links can be added to table content  
with Table Maker’s <icon> tag.
>  See here for more information.

4) Button
Button links can be added to table content  
with Table Maker’s <button> tag.
>  See here for more information.

5) Image
Image links can be added to table content  
with Table Maker’s <image> tag.
>  See here for more information.

1  <a href="https://divi-modules.com" target="_blank">This is a link</a>
2  <cell href="https://divi-modules.com" target="_self">This is a link</cell>
3  <icon href="https://divi-modules.com" target="_blank"></icon>
4  <button href="https://divi-modules.com" target="_self"></button>
5  <image href="https://divi-modules.com" target="_blank"></image>

https://www.w3schools.com/html/html_links.asp
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Adding Shortcodes
Table Maker content can also include Wordpress shortcodes.

Shortcodes can be used to display elements from  
other third-party plugins. For example, you could use  
the Woocommerce [add_to_cart] shortcode to display  
an Add To Cart button in a table cell.

Shortcodes can also be used to create dynamic table 
content. For example, you could use the Advanced Custom 
Fields [acf] shortcode to bring custom field values into  
a table cell.

Note: Shortcodes will not preview in the Visual Builder 
but should display correctly on the front-end, in most cases. 
However, due to the huge variety of shortcodes available 
this functionality is not guaranteed to work in all cases and 
we cannot provide support for it when it doesn’t.

1 [acf field="my_custom_field"]
2 [add_to_cart id="99"]
2 [slider id="99"]
3 [popup id="99"]More Information[/popup]
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Adding Icons
Icons can be added using Table Maker’s <icon> tag.

1) Default Icon
>  The default icon for the table and individual columns can  

be configured under the Content > Table Icons toggles.

2) Custom Icon
The default icon can be overridden by entering an icon  
name between the opening and closing tags.

3) Icon Color
The icon color can be set with the color attribute.

4) Icon Hover Color
The icon hover color can be set with the color-hover attribute.

5) Icon Size
The icon size can be set with the size attribute.

6) Icon Hover Size
The icon hover size can be with the size-hover attribute.

7) Icon Link
The icon link and destination can be set with the href and  
target attributes.

>  A complete list of available icons can be  
found on the Divi-Modules website.

1 <icon></icon>
2 <icon>heart</icon>
3 <icon color="#000000"></icon>
4 <icon color-hover="#000000"></icon>
5 <icon size="32px"></icon>
6 <icon size-hover="150%"></icon>
7 <icon href="https://divi-modules.com"></icon>

https://divi-modules.com/products/table-maker/icons/
https://divi-modules.com/products/table-maker/icons/
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Adding Buttons
Buttons can be added using Table Maker’s <button> tag.

1) Default Button
>  The default button for the table and individual columns can 

be configured under the Content > Table Buttons toggles.

2) Button Text
The default button text can be overridden by entering  
custom text between the opening and closing tags.

3) Button Link
The default button link and destination can be overridden  
with the href and target attributes.

4) Button Style
The default button styles can be overridden with the  
style attribute.

1 <button></button>
2 <button>Buy Now</button>
3 <button href="https://divi-modules.com">Visit</button>
4 <button style="background:ff6786;">Cancel</button>
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Adding Images
A) Image: Selection
To add images to a table you first need add images to the Table 
Maker Settings > Content > Table Images > Image: Selection field. 
Images can then be added using Table Maker’s <image> tag.

>  The default image for the table can be configured  
under the Content > Table Images toggles.

>  See next page for more information. A
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Adding Images (Continued)
Images can be added using Table Maker’s <image> tag.

1) Default Image
An image tag without a number between the tags will  
use the first image found in the Image: Selection field.

>  See previous page for more information.

2) Image Number
An image tag with a number between the tags will use 
the Nth image based on the order in which it appears in  
the Image: Selection field. In the example opposite, the  
fourth image from the Image: Selection field will be used.

>  See previous page for more information.

3) Image Title & Alt Text
The image title and alt text can be set with the title  
and alt attributes.

4) Image Link
The image link and destination can be set with the href  
and target attributes.

>  The default image for the table can be configured  
under the Content > Table Images toggles.

1 <image></image>
2 <image>4</image>
3 <image title="Divi-Modules" alt="Divi-Modules logo">7</image>
4 <image href="https://divi-modules.com">2</image>
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Table Cells
In this section of the documentation we’ll explain  
how to use Table Maker’s <cell> tag to style, hide,  
link and merge individual table cells.
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Cell Styling
Individual table cells can be styled using Table Maker’s <cell> tag. 
Styles can be specified using standard HTML inline-style notation 
or with Table Maker’s own built-in cell styling attributes.

1) Cell Background
The cell background can be set with the background attribute.

2) Cell Text Color
The cell text color can be set with the color attribute.

3) Cell Border
The cell border can be set with the border attribute.

4–7) Cell Border Sides
Individual cell border sides can be set with the border-top, 
border-left, border-right and border-bottom attributes.

8) Inline-Styles
Cells can also be styled using standard inline-style notation.

>  If you are unfamiliar with inline-styles  
there are many tutorials available online.

1 <cell background="#000000">Cell content</cell>
2 <cell color="#000000">Cell content</cell>
3 <cell border="1px solid #000000"">Cell content</cell>
4 <cell border-top="4px dashed #000000">Cell content</cell>
5 <cell border-left="3px dotted #000000">Cell content</cell>
6 <cell border-right="2px double #000000">Cell content</cell>
7 <cell border-bottom="1px inset #000000">Cell content</cell>
8 <cell style="opacity:.5;">Cell content</cell>

https://www.w3schools.com/html/html_css.asp
https://www.w3schools.com/html/html_css.asp
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1 <cell hide="true">Hidden content</cell>

Cell Hiding
Individual table cells can be hidden using Table Maker’s 
<cell> tag and the hide attribute.

Note: Hidden cells are NOT removed from the DOM. 
They are hidden using CSS only and can therefore still 
be discovered with developer tools.
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Cell Links
Individual table cells can be made into links using Table 
Maker’s <cell> tag and the href and target attributes.

1  <cell href="https://divi-modules.com" target="_self"> 
This is a link</cell>
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Cell Merging
Table cells can be merged and made to span multiple columns and rows  
using Table Maker’s <cell> tag and the colspan and rowspan attributes.

In this simple example notice how the words Foxtrot and Kilo are covered  
by the colspan in column 2, and the words Mike, November and Oscar are 
covered by the rowspan in column 4. Cells which are covered by a colspan  
or rowspan can be left empty or have placeholder text if you wish.

Note: You cannot merge cells across the boundary from one table part to 
another. For example, if you begin a rowspan within a Column Header, it cannot 
merge beyond the Column Header area into the Row Header or table body.

1 Row 1
2 Row 2
3 Row 3
4 Row 4
5 Row 5

1 Foxtrot
2 Golf
3 Hotel
4 India
5 Juliett

1 Kilo
2 <cell rowspan="4">Lima</cell>
3 Mike
4 November
5 Oscar

1 <cell colspan="3"> Alpha</cell>
2 Bravo
3 Charlie
4 Delta
5 Echo

Column 1 Column 2 Column 3 Column 4
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Troubleshooting
In this section of the documentation we’ll explain some of  
the more common problems that Table Maker users experience  
when creating tables.

It’s important to note that sometimes a table may look fine in the  
Visual Builder but display incorrectly on the front-end of the website.  
This is usually an indication of one of four common problems:

1)  HTML entered by the user contains errors.
2)  HTML entered by the user includes reserved characters.
3)  HTML entered by the user includes smart-quotes, not inch-marks.
4)  There is a plugin conflict of some kind.

Each of the above scenarios are discussed below.
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Reserved Characters
When using HTML in your Table Maker content it’s not  
only important that it is entered correctly but also that  
you avoid using any characters which are reserved for  
use by the HTML language itself.

Some common characters which should not be used  
in Table Maker content include the less-than, greater-than, 
ampersand, quote, and apostrophe characters.

To use these characters in table content you should either 
replace them with Table Maker’s replacement characters or 
HTML entities, as shown in the chart opposite.

>  See here for more information on HTML entities. Example:

CHARACTER
NAME

CHARACTER
SYMBOL

TABLE MAKER 
REPLACEMENT

HTML ENTITY 
NAME

HTML ENTITY 
NUMBER

Less-than < {{lt}} &lt; &#60;

Greater-than > {{gt}} &gt; &#62;

Ampersand & {{amp}} &amp; &#38;

Quote " {{quot}} &quot; &#34;

Apostrophe ' {{apos}} &apos; &#39;

1 10 {{lt}} 50
2 50 {{gt}} 10
3 Salt {{amp}} Pepper
4 {{quot}}This is a quote{{quot}}
5 There{{apos}}s

1 10 &lt; 50
2 50 &gt; 10
3 Salt &amp; Pepper
4 &quot;This is a quote&quot;
5 There&apos;s

10 < 50
50 > 10
Salt & Pepper
"This is a quote"
There’s

10 < 50
50 > 10
Salt & Pepper
"This is a quote"
There’s

https://www.w3schools.com/html/html_entities.asp


1 <cell href=“https://divi-modules.com”>Smart-Quotes</cell>
2 <cell href="https://divi-modules.com">Inch-Marks</cell>
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Smart Quotes
When using HTML in your Table Maker content it’s important  
to be sure that any quotation marks used in HTML attributes  
are inch-marks and not smart-quotes.

A) Smart-Quotes
Smart-quotes appear as italicized quotation marks.

B) Inch-Marks
Inch-marks appear as straight quotation marks.

Although the visual difference between smart-quotes and  
inch-marks is subtle, if smart-quotes are used they could affect  
the appearance and proper functioning of the table.

Note: The replacing of inch-marks with smart-quotes  
sometimes occurs when copying and pasting content into  
the table rather than typing it in manually.

Smart-Quotes:

Inch-Marks:

A

B
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Vertical Scrolling
Table scrolling is only visible when needed. While 
horizontal scrolling will be visible when the table  
is wider than the available space, vertical scrolling 
will only be visible if the table is given a Height or 
Max-Height that is less that the overall height of  
the table itself.

A) No Scrollbars
If no Height or Max-Height is given to the table then 
all table rows will flow down the page and vertical 
scrollbars will never be visible.

B) Scrollbars
If a Height or Max-Height that is less that the height 
of the table is given, vertical scrollbars will appear.

A B
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Plugin Conflicts
Leap by Ezoic
There is a plugin conflict with the Leap plugin. This plugin removes  
Table Maker’s default CSS styling, causing tables to display incorrectly  
on the front-end. The solution is to disabled Leap’s “CSS Optimization”  
and “Remove Unused CSS” options.

Broken Link Checker by WPMU
There is a plugin conflict with the Broken Link Checker plugin.  
This plugin breaks the layout of Table Maker tables which contain links.  
There are three possible solutions:

1)  Disable Broken Link Checker when your site is live  
and only enable it occasionally to find broken links.

2)  Go to the WP Admin > Settings > Link Checker >  
Which Links To Check > Exclusion List and add any  
used Table Maker links to the list.

3)  Go to WP Admin > Tools > Broken Links and mark  
any used Table Maker links as Not Broken.
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Known Issues
Global Tables
Tables which are saved to the Divi Library as a Global item may not  
display correctly on the front-end. If experiencing problems with tables  
in the Divi Library it is recommended to leave the Global option OFF.

Embedding Tables
Occasionally Divi-Modules customers request help with embedding  
Table Maker tables inside other modules, such the Tabs, Toggle, or 
Accordion modules. While it may be technically possible to do this, it is  
not something that is officially supported. You are welcome to try but  
you do so at your own risk and we cannot provide support for it.

Translating Tables
Due to the way that table content is processed, Table Maker tables do  
not support the WPML plugin’s automatic translation mode. Instead,  
we recommend trying the WPML manual “Translating Your Site Yourself ” 
mode or using a translation plugin such as Polylang.

Search Results
Occasionally, unprocessed Table Maker table content can display in 
website search results. The solution is to manually enter a page expert 
into the Excerpt field provided by Wordpress, rather than allowing it to  
be automatically generated.
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